Webmin Error - Perl execution failed

Building complete list of packages …

Now installing httpd mod_.* …

HTTP/1.0 500 Perl execution failed Server: MiniServ/1.900 Date: Thu, 21 Mar 2019 12:52:04 GMT Content-type: text/html; Charset=iso-8859-1 Connection: close

Error - Perl execution failed

Undefined subroutine &package_updates::update_system_install called at ./package-updates-lib.pl line 391.
Eny solution ?

Error got then installing Apache Webserver module…

1 Like

Just update package-updates/package-updates-lib.pl.

can you tell how? first time using webmin…

I never used webmin -
You can try PLESK -pleask its free on digital ocean & vultr.
If you install on your server .
I will give you license for 1 year (somewhat nulled)

im using plesk on home server … but i need for client good web panel …cwp he not like …

ok i found the way …

Okay, you can open Dropdown Command Line for Webmin by clicking an icon in navigation menu or using hotkey Alt+K and run the following command:

For Ubuntu/Debian:

curl https://raw.githubusercontent.com/webmin/webmin/5d0bd909f0bfe45092ab783f95e4e989e5ed8b8f/package-updates/package-updates-lib.pl | cat > /usr/share/webmin/package-updates/package-updates-lib.pl

For RHEL based (CentOS/Fedora):

curl https://raw.githubusercontent.com/webmin/webmin/5d0bd909f0bfe45092ab783f95e4e989e5ed8b8f/package-updates/package-updates-lib.pl | cat > /usr/libexec/webmin/package-updates/package-updates-lib.pl

In case you don’t have curl installed, then install it. To install it run for Debian/Ubuntu the following command:

apt-get -y install curl

and for RHEL :

yum -y install curl

Then Package Manager will work just fine.